Skip to content

[postgres] Issue with the mounting point #123

Description

@guzmud

Description

Starting the docker stack from scratch leads to a pgsql failure: ✘ Container xtm-pgsql-1 Error dependency pgsql failed to start 2.1s.

This may be linked to docker-library/postgres#1409 and a recent update of the pgsql docker images. Screenshots and suggested fix can be found at the bottom of this issue.

Environment

  1. OS: Windows
  2. Runner: podman
  3. OpenAEV-Platform/docker version: master

Reproducible Steps

Steps to create the smallest reproducible scenario:

  1. Down any currently running OpenAEV docker stack
  2. Delete previously existing docker volumes
  3. podman compose -f .\docker-compose.yml up -d

Expected Output

Works

Actual Output

Fails on pgsql

Additional information

Output of the podman compose
Image

Log details

Image

Suggested fix

Following the details provided by the error message, replace /var/lib/postgresql/data with /var/lib/postgresql

Image

Output of the podman compose after fix

Image

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Labels

bugType: something isn't working (fix:).

Type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions