I'm attempting to deploy a local image using balena deploy, however I keep getting HTTP 500 response during deployment. I'm using Podman to build images, though that shouldn't make a difference in this scenario. Thoughts?
[Debug] Parsing input...
[debug] Event tracking error: Timeout awaiting 'response' for 0ms
[Debug] Loading project...
[Info] Creating default composition with image: "localhost/slint-demo:0.0.1"
[Debug] Creating project...
[Info] Everything is up to date (use --build to force a rebuild)
[Info] Creating release...
[Debug] Tagging images...
[Debug] Authorizing push...
[Debug] Requesting access to previously pushed image repo (v2/6d3df59f4edf98272b9cb83bae54df1d)
[Info] Pushing images to registry...
Retrying "registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3:latest" after 2.0s (1 of 2) due to: Error: (HTTP code 500) server error - trying to reuse blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 at destination: checking whether a blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 exists in registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3: requested access to the resource is denied
Retrying "registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3:latest" after 2.8s (2 of 2) due to: Error: (HTTP code 500) server error - trying to reuse blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 at destination: checking whether a blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 exists in registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3: requested access to the resource is denied
[Debug] Saving image registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3
[Debug] Untagging images...
[Info] Saving release...
[Error] Deploy failed
(HTTP code 500) server error - trying to reuse blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 at destination: checking whether a blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 exists in registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3: requested access to the resource is denied
Error: (HTTP code 500) server error - trying to reuse blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 at destination: checking whether a blob sha256:418dccb7d85a63a6aa574439840f7a6fa6fd2321b3e2394568a317735e867d35 exists in registry2.balena-cloud.com/v2/0dd11b9c073f3d0dc33ca7690ebd0db3: requested access to the resource is denied
at /home/nik/balena/node_modules/docker-modem/lib/modem.js:383:17
at handler (/home/nik/balena/node_modules/docker-modem/lib/modem.js:426:11)
at IncomingMessage.<anonymous> (/home/nik/balena/node_modules/docker-modem/lib/modem.js:415:9)
at IncomingMessage.emit (node:events:531:35)
at endReadableNT (node:internal/streams/readable:1698:12)
at process.processTicksAndRejections (node:internal/process/task_queues:90:21)
For further help or support, visit:
https://www.balena.io/docs/reference/balena-cli/#support-faq-and-troubleshooting
I'm attempting to deploy a local image using
balena deploy, however I keep gettingHTTP 500response during deployment. I'm using Podman to build images, though that shouldn't make a difference in this scenario. Thoughts?